Block Editing Issue

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Block Editing Issue

RobertDD
This post was updated on .
Hi @all, I just startet a stream in Zulip chat about the following but found out later that this place here is perhaps more appropriate for asking..I appreciate to have librecad for my cad project..There is just one problem I have when I want to change a block: If I want to select an object within block editing mode, it more than often brings up the request "no entity found" - I tried with current version and the previous one (2.1.3)..Is this a known issue or do I missed some basic idea about block editing ? I attached a drawing of mine where this occurs for those who want to check the behaviour..Actually the behaviour should occure in any blocks of the sample drawing..e.g. if one tries to move a line its nearly impossible to select it. In the meantime I found out, that the behaviour is connected to the drawing file itself..when I start with a new file its not there..S_R.dxfcheers robert
Reply | Threaded
Open this post in threaded view
|

Block Editing bug

RobertDD
Hello dear Developer,

in order to clarify my problem I attached 2 files. In file named S_7.dxf it is very easy to edit the block named "Z_Quer_1" i.e. if one wants to lengthen some lines or so. However in file S_8.dxf which is a derivat from "S_7.dxf" the same operation is not possible anymore. I already compared both files and there are just a few differences between them but still have no clue where to find the reason..I have to admit that I tried to establish this topic some month earlier in user part of this forum but yield no answer, the same with zulip chat..I hope the problem is described precise enough this time - I would appreciate any help. Thanks robert
Reply | Threaded
Open this post in threaded view
|

Re: Block Editing bug

LordOfBikes
Administrator
Hi Robert,

I can reproduce your issue with S_8.dxf.
But now the question is, how was S_8.dxf created?
Can you describe the modifications you applied on the way from S_7.dxf to S_8.dxf?

Armin
Reply | Threaded
Open this post in threaded view
|

Aw: Re: Block Editing bug

RobertDD
 
Hello Armin,
 
thank you for this message. Actually the original files are from first quarter of 2017. Therefore I have no clue what I did at this time. Maybe I worked with 2 different versions of librecad on these files but I guess not..
I just found that the problem in S_8.dxf seems to be connected two line 1176. If I change the value there from 0 to 1 (according to S_7.dxf) the behaviour gets normal again. But how this value is changed via librecad - I cannot imagine.
Best regards robert
Gesendet: Samstag, 04. Mai 2019 um 23:24 Uhr
Von: "LordOfBikes [via LibreCAD]" <[hidden email]>
An: RobertDD <[hidden email]>
Betreff: Re: Block Editing bug
Hi Robert,

I can reproduce your issue with S_8.dxf.
But now the question is, how was S_8.dxf created?
Can you describe the modifications you applied on the way from S_7.dxf to S_8.dxf?

Armin

 
If you reply to this email, your message will be added to the discussion below:
http://forum.librecad.org/Block-Editing-Issue-tp5716968p5717328.html
To unsubscribe from Block Editing Issue, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Aw: Re: Block Editing bug

LordOfBikes
Administrator
Robert,

the value stored in line 1176 is the grid state.
I've checked this and indeed, when I open S_8.dxf, grid is off. Then I switch grid on (Ctrl + g) and editing the block works fine.
After toggle the grid off again editing the block still works.

I'll open an issue for this bug, many thanks for reporting.

Armin

Reply | Threaded
Open this post in threaded view
|

Re: Aw: Re: Block Editing bug

LordOfBikes
Administrator
Reply | Threaded
Open this post in threaded view
|

Aw: Re: Re: Block Editing bug

RobertDD
Hello Armin,
 
thank you very much for this explanation and also for the bug report, this helps me greatly..Best regards robert
 
 
Gesendet: Sonntag, 05. Mai 2019 um 02:54 Uhr
Von: "LordOfBikes [via LibreCAD]" <[hidden email]>
An: RobertDD <[hidden email]>
Betreff: Re: Aw: Re: Block Editing bug
track back:
https://github.com/LibreCAD/LibreCAD/issues/1094
 
If you reply to this email, your message will be added to the discussion below:
http://forum.librecad.org/Block-Editing-Issue-tp5716968p5717331.html
To unsubscribe from Block Editing Issue, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Aw: Re: Re: Block Editing bug

LordOfBikes
Administrator
No problem, you're welcome!