Can't compile Librecad

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Can't compile Librecad

savio
The error is:

fatal error: QStandardPaths: Arquivo ou diretório não encontrado (file or directory not found)

I am using Debian Jessie.

The package that contains QStandardPaths is installed.

apt-file search QStandardPaths
qtbase5-dev: /usr/include/x86_64-linux-gnu/qt5/QtCore/QStandardPaths

aptitude search qtbase5-dev
i   qtbase5-dev                                       - Qt 5 base development files

[]'s
Sávio M Ramos
Arquiteto, Rio, RJ
Só uso Linux desde 2000
www.debian.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't compile Librecad

LordOfBikes
Administrator
apt only tells you, that Qt5 is installed on your system.

That doesn't mean that it is used, maybe there is Qt4 installed too?

Use
qmake --version
to see which versions of qmake and Qt are used.

If your machine uses the wrong Qt version, there's a package qtchooser which simplifies switching between Qt versions.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't compile Librecad

savio
$ qmake --version
QMake version 3.0
Using Qt version 5.3.2 in /usr/lib/x86_64-linux-gnu


I tried to do this:

qtchooser -qt=4 -run-tool=qmake -r

Than, make -j4

The error is the same.

I think that the problem is that qt4 debian package don't have the file: QStandardPaths

P.S. I compiled Librecad in this machine in:

Versão: 2.2.0-alpha-187-gdb449e8
Compilador: GNU GCC 4.9.2
Compilado em: May 25 2017
Versão do Qt: 5.3.2
Boost Version: 1.55.0
Sávio M Ramos
Arquiteto, Rio, RJ
Só uso Linux desde 2000
www.debian.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't compile Librecad

LordOfBikes
Administrator
For Qt4 this is expected, as QStandardPaths was introduced with Qt 5.0.

Thus
savio wrote
QMake version 3.0
Using Qt version 5.3.2 in /usr/lib/x86_64-linux-gnu
should be sufficient to compile LibreCAD.

I will check things later on my Ubuntu machine, where it builds fine.
Latest sources also build fine on launchpad.net for librecad-daily ppa.
But I reckon, that it is something with the environment/configuration on your Debian box.

Armin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't compile Librecad

savio
I upgraded to Debian 9.0. It is working now.

I used this:

qmake -qt=qt5 -r
Sávio M Ramos
Arquiteto, Rio, RJ
Só uso Linux desde 2000
www.debian.org
Loading...