Cannot print to my home computer printer

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Cannot print to my home computer printer

retired72#%
I have tried all I have read on the forum and still cannot seem to print. My print preview is always blank and the print command yields blank sheet. I am using window 10 ---- Please help
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot print to my home computer printer

dellus
Construction layer activated? Entities on construction layer will not be printed and thus don't appear in print preview. Switch off so that's it greyed out.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot print to my home computer printer

retired72#%
Thanks   but I tried this and no help ---  Perhaps I'm not doing it right but it is grayed out but still will not print ???
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot print to my home computer printer

georgesbasement
Something like this happened to me also. I "solved" it by discovering that exporting as a bitmap passes through a page where you have to specify the dimensions of the bitmap in pixels. For some unfathomable reason, the default was "ten" (meaning ten by ten pixels) which explained to me after a couple of puzzling outputs from my printer that I was cramming my entire drawing into a rather too small little square, of 100 pixels in area. After expanding to 1000 by 1000 pixels, the saved bitmap could be opened into the gimp with a rather better appearance.

Another pitfall is forgetting to widen the drawing's lines, because at the original widths they are invisible in the output of a good printer. I made mine something like half a millimeter wide, opened the bitmap in the gimp, added some blur, reduced the brightness and increased the contrast drastically and got a printout that was decent;y readable. It also helped to increase the printing density.

 [HP 1505n laserjet printer.]

Good luck,
georgesbasement
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot print to my home computer printer

dellus
This post was updated on .
In reply to this post by retired72#%
Can't think of any other reason. What is the line width? You could provide a sample drawing file for examination (see at 'More').
Oh, might also be the drawing is far off the paper range, paper size not properly set, scale exorbitantly wrong or something in that direction.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot print to my home computer printer

retired72#%
In reply to this post by georgesbasement
Thank you so much for Replying to my post. I must apologize for being such an idiot, but I'm not sure I can follow your recommendations. I tried to do the export thing but probably did it wrong --anyway it did not work. If you have any patience left is there any way you could walk me through creating a simple straight line and trying to print it.  I have read and printed out the online manual but cannot find an example of creating a drawing and printing it.  So sorry for being such a dummy.   Regards Dan
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot print to my home computer printer

georgesbasement
Hi Dan -

Not an idiot. Just a beginner; we're all idiots at this stage ...

Here's my method:
Starting with your drawing, click on "File" in the main menu bar and then select "Export." You will then see a popup window, and at the bottom of that window is a line entitled,"Files of Type" to the right of which is a pair of "up" and "down" black triangles. Click on either one (it doesn't matter which one !) and you will be presented with a bewildering array of choices. I pick "Windows Bitmap" which I know from past experience can be edited with Gimp. I add the characters, ".bmp" to the name of my file and then click "Save." Then you will see a popup within which you _must_ make some changes. "Auto" is fine for the resolution, but the next line below that will show a pair of digits which are the X and Y dimensions of your drawing. With the drawing on which I just tried this, I saw just an "8" and a "6." I changed those numbers (which are the X & Y dimensions of my drawing) to 8000 and 6000, which I have just discovered recently are the pixel dimensions of the bitmap image of the drawing. Leaving them as-is will reduce the prited output of your drawing to a mere dot on the paper. 8000 by 6000 makes a much more useful image.

In a previous go-round with printing I tried to save as a .JPG, but the very same popup as for the .BMP version appeared, but the X & Y dimensions were such large numbers that I didn't even comprehend them. Therefore, I recommend going through the bitmap route, as it doesn't compromise the quality of your drawing.

It helps a lot if you have previously added a folder called "Drawings" to your Home folder, which puts it in the same rank as "Documents" and "Pictures" which appear to be a default of my version of Linux, called Trisquel. LibreCAD likes to put all your saved drawings to the Drawings folder after you have picked Drawings as the destination of your saved output a few times.

You should then go to your Drawings folder, find the one you just saved, click on it and select "Open With" which ought to present you with a choice of image editors. I use Gimp (available for just about all PC platforms, including Windows) which is very similar to Photoshop, but without a few of that program's handy shortcuts. However, Gimp will open and allow you to edit just about any format of an image. Look up Gimp.org if you don't already have it. It is not proprietary and is freely downloadable.

In your image editor, you will have the ability to change contrast and brightness, but blindly doing that first will produce some awful-looking jagged lines pretending to be curves. Instead, find a way to blur the image, which will have the effect of widening those lines when you later try to darken all the lines to make them print less faintly than will be the output of a direct printout of the original bitmap image. Gimp has a menu item called "Blur" and I use it to jitter the pixels by +/- 1.5 to 2.5 pixels. Gimp will give you the opportunity to evaluate the effect of your choice before applying it to the entire image. Once the image is blurred by that small amount, you can then apply changes to contrast and brightness. I reduce brightness first, then increase contrast. The first cycle of this won't be sufficient. After closing the "Brightness-Contrast" window in Gimp, open it again and apply the reduced brightness, increased contrast steps again ... their effects are cumulative, but you can undo them and start over after a large number of editing steps, so there isn't a "gotcha" stage to the editing process. After you see a suitably contrasty image with sufficiently dark lines of somewhat wider width, you can then try using the "Sharpen" filter which you will find in the "Filters" menu under "Enhance." That will narrow the lines and make their edges more distinct. If you overdo the "Sharpen" filter, the image may become somewhat pixelated (which you will understand when you see it !).

If you overdo the darkening of your drawing, dark patches may appear; undoing the changes can restore the image, but if you have already saved it, then you'll have to brighten the image with the image editor to eliminate the dark patches. This is more of a problem with scanned images than with LibreCAD drawings.

This may help if my English isn't too complex ...

Best regards,
georgesbasement
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot print to my home computer printer

retired72#%
Thanks for all your help .  I will try it and hopefully succeed !!   -- Regards  Dan
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot print to my home computer printer

dellus
There shouldn't be any need to print via bitmap export.
To set up a drawing, it is not necessary but helpful to first draw a rectangle as a frame in the size of the papersize, you may start it at the origin, coordinates 0,0, the red cross. Set that papersize also in 'Options' - 'Current Drawing Preferences'. Use and set your units, metric or imperial, inches, mm, m or whatever. It's easiest if drawing units and papersize units are identical, for instance mm and A4 ( 297x210 mm). If you intend a scale other than 1:1, for instance 1:100, in that case the drawn frame has to be 100 times larger.
Now set the line width in the pen options tab (at the top of the screen) to 0.25 mm (standard pen for thin lines) or maybe 0.5 mm and draw a simple line with the mouse somewhere within that papersize frame.
Go to print preview, set the scale (1:1 or maybe 1:100), click 'center to page' and click 'print'. Be sure you have in the following OS related setup the proper papersize set also.
If you don't succeed I can make you a template if you tell me your specifications.  
Loading...