Correct prodedure for avoiding file permission problem.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Correct prodedure for avoiding file permission problem.

Jim Thompson
The old thread that I opened about this has been changed to "read only" here:

http://forum.librecad.org/File-permission-problems-td5710234.html#a5711001

It was almost resolved, but not yet totally clear to me. My apologies to all respondents if I am a bit obtuse here.
What I would like to know is what is the correct starting procedure before and during the opening of a new file drawing, to set all permissions to "read and write", to safeguard against striking this obstacle and possibly (actually in the past) losing a drawing again.

I need to know Specifically:

1. Any and all places where full "read - write" permission need to be set before starting to draw.

2. What is a totally reliable way to prove the above is successful before spending hours or days on it?  Can the file can be opened without the access warning. Is it ok just to start the drawing, close down and open it from /home/drawings?  If that opens, proceed with confidence?

Thanks for your patience and assistance.

Jim.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Correct prodedure for avoiding file permission problem.

Jim Thompson
I have set all permission to "read and write" in my Linux Mint 17.2 file manager Nemo as per the screenshot as a starting point:

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Permission settings changes back.

Jim Thompson
This post was updated on .
When I opened my file manager again to check the changes, it had reverted to the blank settings below. Should I re-start my computer to "hold" the settings I select? Maybe this is a problem for the Linux Mint forums?

I did restart my computer, but the changed reverted to blank, as above.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Permission settings changes back.

Jim Thompson
I did try restarting the computer after setting all three fields to "read and write". When it rebooted, the fields had defaulted back to a blank setting. What does this mean?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Permission settings changes back.

ravas
Administrator
This post was updated on .
Open a terminal and input:
ls -l parent_dir_of_the_dir_you_are_trying_to_save_to

It will list the owner and group in the third and fourth columns.

You can also use: stat dir_you_are_trying_to_save_to

If it says root is the owner, then that is the problem.
You would need to log in with the su command,
and then change the owner with chown.
This is assuming the folder was mistakenly created as root.

http://www.linfo.org/chown.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Permission settings changes back.

ravas
Administrator
Also, the path /home/drawings would not be what you want.

You want /home/jim/drawings

Logged into a terminal as jim you can make it with: mkdir drawings
Loading...