General scale & unit precision not working

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

General scale & unit precision not working

plopske
Hi, I'm new to LibreCAD. I am trying to make my first real drawing but I can't get passed this problem:

1. I want my drawing to be to scale 1:20. I found I can do this by setting: Options/Current Drawing
Preferences, tab: Dimensions, General Scale: 20
When I set this and add the dimensions to my drawing the arrow heads and dimension text are huge
(20x normal?), but dimension is still shown as 90 for a 90mm line, not 1800mm.

2. I want the dimensions to appear in mm without decimals, so I set Options/Current Drawing
Preferences, tab: Units, Main drawing unit: Millimeter; Format: Decimal; Precision 0
I expect (without the scaling) to get dimension as 90, but I see 90.0000 (like I didn't set the precision).

What am I doing wrong here?

Thanks for your help in advance.

Kind regards,

Rob

I am using:
Version: 2.1.3
Compiler: GNU GCC 4.9.1
Compiled on: Sep 23 2016
Qt Version: 5.4.1
Boost Version: 1.60.0
System: Windows 8.1
Reply | Threaded
Open this post in threaded view
|

Re: General scale & unit precision not working

dellus
1. General Scale enlarges the dimensions elements as they are scaled down in the printing process again. If you are in millimeters, set the text size to 2.5 mm. It's the size you will get on paper then. When printing, do it via Print Preview and set the scale there too (1:20).

2. The precision for dimensions is set at Options/Current Drawing Preferences, tab: Dimensions, Format units , Linear precision (0 in your case).