Horizontal Snap grid

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Horizontal Snap grid

LibreCraig
Hi:

Another new user here with LibreCAD 2.1.3.  I must be missing something obvious.  I'm trying to draw a small part -- 2 X 2 X 0.5 inches.  It would be ideal if the snap was in sixteenths of an inch (0.0625") because a number of the features of the part are measured that way.  In Options > Current Drawing Preferences > Units, I select Inch and Fractional.  In the main drawing window, with Snap On Grid selected, the mouse jumps vertically from one grid line to the next.  But not horizontally.  It stays on zero.

Also, the position readout in the lower left displays values like "0 , 24".  Does that mean Y equals 24 sixteenths?

I also tried working in decimal inches with 4 places of accuracy but basically ran into the same problem.

What do I need to do?

Craig
Reply | Threaded
Open this post in threaded view
|

Re: Horizontal Snap grid

LordOfBikes
Administrator
It seems, that you have activated Vertical Restriction mode.
See this post: http://forum.librecad.org/how-to-calculate-a-surface-tp5716879p5716882.html
It is about Horizontal Restriction, but the Vertical Restriction button is right beside it.

The coordinates are shown in units. Means when you have set Inch in drawing preferences, it is 24 Inch.
You have to zoom in more, then you will get a grid that is 1/16th (the dots) and full inches are marked as continuous doted lines.
Grid is dynamically in LibreCAD, it depends on the zoom level.

Armin
Reply | Threaded
Open this post in threaded view
|

Re: Horizontal Snap grid

LibreCraig
On Feb 13, 2019, at 10:40 AM, LordOfBikes [via LibreCAD] <[hidden email]> wrote:

It seems, that you have activated Vertical Restriction mode.
See this post: http://forum.librecad.org/how-to-calculate-a-surface-tp5716879p5716882.html
It is about Horizontal Restriction, but the Vertical Restriction button is right beside it.

The coordinates are shown in units. Means when you have set Inch in drawing preferences, it is 24 Inch.
You have to zoom in more, then you will get a grid that is 1/16th (the dots) and full inches are marked as continuous doted lines.
Grid is dynamically in LibreCAD, it depends on the zoom level.

Armin

Thanks, I knew it had to be something I was overlooking.  Vertical Restriction mode _was_ enabled.  I didn’t expect anything like that to stay set after relaunching the program.

Is there a quick way to get to a known zoom level like 1:1?

Craig

Reply | Threaded
Open this post in threaded view
|

Re: Horizontal Snap grid

dellus
"Is there a quick way to get to a known zoom level like 1:1?"
In drawing mode there is no such possibility. In Print Preview you can set a scale, what has a similar effect.
What you can do is to draw a frame larger than the drawing contents, for instance in paper size, and then do an Auto Zoom. So you will always get the same zoom level.
On screen there is not really something like 1:1. With some calculating and experimenting you could get that frame for Auto Zoom to approximately produce 1:1 appearance physically on screen like on paper. This depends on your screen size and resolution.