RS_MAXDOUBLE and RS_MINDOUBLE

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RS_MAXDOUBLE and RS_MINDOUBLE

R. van Twisk
Administrator
I quickly scanned the use cases for RS_MAXDOUBLE and RS_MINDOUBLE

and it seems like they are used to ‘fix’ problems that currently exists in LibreCAD2.
For example I see usage in getNearestEndPoint(..)

I don’t think we need it in LibreCAD 3, if we need some sort of a limited that’s not a
intended as given by a compiler constant then we need a much better name.

My advice is to remove them, if you think you really really need them, please let me know!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: RS_MAXDOUBLE and RS_MINDOUBLE

gaganjyot
Ries, I don't think we need them. Since I was porting the code from LC2, I brought these just for testing. I agree these should be removed or if required renamed.

Gaganjyot
Loading...