Random accepted keycode

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Random accepted keycode

ahmadraniri
I found something strange when activate the "keycode mode".
some command are accepted but there are some not accepted. For example, when we type "li" it directly working without press the enter button but when we type "rec" it doesn't working and we need to press the enter button.
How do we make all command work without press the enter button?
I'm sorry for the grammar, I hope you all understand what I am saying.
librecad 2.2.0 compiled from source.
Os debian 9 32 bit.
Reply | Threaded
Open this post in threaded view
|

Re: Random accepted keycode

LordOfBikes
Administrator
I wasn't involved in keycode mode nor do I use it. Off the top of my head, keycode works with 2 letter short cuts. But not all commands have a 2 letter shortcut to my knowledge.

I found these wiki pages about commands:
https://wiki.librecad.org/index.php?title=Commands
https://wiki.librecad.org/index.php?title=A_short_manual_for_use_from_the_command_line

Both sites show that li is a short cut for line, but rect has no 2 letter short cut.
So it's needed to add unique 2 letter shortcuts to all commands missing it.
This can't be done in local settings, must be programmed in source code.

Armin
Reply | Threaded
Open this post in threaded view
|

Re: Random accepted keycode

ahmadraniri
oh... it's really help... thanks sir