RestrictOrthogonal (rr) key command working auto-active.

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

RestrictOrthogonal (rr) key command working auto-active.

sunggus
Hi All,

RestrictOrthogonal (rr) key command working auto-active.

I used LibreCAD 2.1.3 with OS Vista Home Premium. My FC normally is working fine. But yesterday a strange occurred quite frequently, like there was giving rr command to the command line. Sometime it occurred before, but not so many. But yesterday like long continuous command rr were given in the command line. Before, the Keycode Mode in the Application preference was activated/enabled (ticked/checked). Then I deactivated (disabled) it. But still the same, still occurred. Because I used wireless mouse, I try to change to the conventional wired mouse, I take out the USB dongle, but still the same. What was the problem? Right now I am working with the wireless mouse and the rr is not occurred.

Thank you in advance of your kind help.

Best regard,
Reply | Threaded
Open this post in threaded view
|

Re: RestrictOrthogonal (rr) key command working auto-active.

sunggus
Accepted Keycode: pp Now, there is another annoying "command" in the command line: Accepted Keycode: pp, which I never knew before. Quite disturbing especially when working with detail. Any kind help will be appreciated.

Best regard,
Reply | Threaded
Open this post in threaded view
|

Re: RestrictOrthogonal (rr) key command working auto-active.

LordOfBikes
Administrator
Concerning the keycode mode switching, maybe this option needs a restart of the application to take effect.
I don't remember and don't have a 2.1.3 to test now.
In 2.2.0 keycode mode works without restart, but it has moved from application preferences to a menu button in the command line.

Anyhow, I don't see how LibreCAD should auto generate these commands, I'd suspect the keyboard as source of this weird behavior. Or maybe it comes from Windows, any ease of access software? Maybe activated accidentally or a stuck keyboard key?

Armin
Reply | Threaded
Open this post in threaded view
|

Re: RestrictOrthogonal (rr) key command working auto-active.

sunggus
I will try to find the cause. But for now, there is not problem, even I backed to use my wireless mouse and so do when I used the wired one. But thank you anyway for the comment have helped me to look another possibility.

Anyway, is that LibreCAD 2.2.0 Alpha already stable? I mean, will I save to uninstall my FreeCAD 2.1.3 and install the 2.2.0?

Best regard,