Translation...

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Translation...

Rudi
Hi! I'm new here, so sorry if this is not the right forum for this issue...

In the german translation, if you select "Datei - Schließen" (File - Close) from the menu, in the next window there are 3 of the 4 buttons in english:

Save - Speichern unter - Close - Cancel

I think this should be:

Speichern - Speichern unter - Schließen - Abbrechen

Rudi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Translation...

dxli
Administrator
please register your account at translate.librecad.org

AND tell us your account name here. An account needs to be approved because we received too much spam previously.

Rudi wrote
Hi! I'm new here, so sorry if this is not the right forum for this issue...

In the german translation, if you select "Datei - Schließen" (File - Close) from the menu, in the next window there are 3 of the 4 buttons in english:

Save - Speichern unter - Close - Cancel

I think this should be:

Speichern - Speichern unter - Schließen - Abbrechen

Rudi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Translation...

Rudi
I already registered there as Rudi - the same account name as here...
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Translation...

dxli
Administrator
Your account should work for you now.

Please let me know if there's a problem.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Translation...

LordOfBikes
Administrator
In reply to this post by Rudi
Rudi,

which LibreCAD version do you use?
The window you are talking about is a Qt standard dialog. The translation for this dialog is not found on the translation server.

For the Qt dialogs there should be a qt_de.qm in the LibreCAD\resources\qm\ folder beside the librecad_de.qm and plugins_de.qm files.

The qt_xx files were added before LibreCAD 2.0.0rc2 version. If your version is older than that, you have to upgrade. When your version is 2.0.0rc2 or above there is another problem. Then you have to check if the qt_de.qm file exists in your installation.

Armin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Translation...

Rudi
Hi Armin!

My Version-Info:

Version: master
Quelltextversion: 2.0.4
Compiler: GNU GCC 4.8.0
Qt Version 5.2.1
Erstellt am: Jun 2 2014

There is a qt_de.qm file in that folder, but its size is only 172 bytes....

Rudi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Translation...

dxli
Administrator
seems to be packaging issue.

https://github.com/LibreCAD/LibreCAD/blob/master/librecad/ts/librecad_de.ts

Rudi wrote
Hi Armin!

My Version-Info:

Version: master
Quelltextversion: 2.0.4
Compiler: GNU GCC 4.8.0
Qt Version 5.2.1
Erstellt am: Jun 2 2014

There is a qt_de.qm file in that folder, but its size is only 172 bytes....

Rudi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Translation...

LordOfBikes
Administrator
In reply to this post by Rudi
Rudi,

for Qt 5.2.1 the size of 172 Byte is correct for qt_de.qm.

That means, that there is no German translation for Qt libraries from the Qt people. For earlier versions of Qt it works.

I will investigate the reason for this and take care about when the next LibreCAD release will be prepared.

Armin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Translation...

LordOfBikes
Administrator
Rudi,

Qt5 has changed the handling of translation files.
qt_de.qm has only a list to other qm files which are not bundled with the LibreCAD installer.

Please try to add these files to the folder where qt_de.qm is located:
qtbase_de.qm
qtscript_de.qm
qtquick1_de.qm
qtmultimedia_de.qm
qtxmlpatterns_de.qm

The problem is, that there are languages with the old system, one qt_??.qm file with all translations and couple of languages with the qt_de.qm system.
We have to figure out, how we could handle this in a common way and why this two different solutions exists in Qt.

Armin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Translation...

LordOfBikes
Administrator
I have tested this now and it worked for me as expected.

I fixed it with commit d9a59073.
With the next release 2.0.5 installer the Qt library translation files should be installed correct on Windows.

If this is an issue on Debian/Ubuntu Linux, one can add the package qttranslations5-l10n using the preferred packet manager. Then add the translation path /usr/share/qt5/translations in LibreCAD's application settings. Use a semicolon (;) to separate the path from the recources/qm path.
After a restart of LibreCAD the Qt translations should be loaded.

On OSX this is an issue on too, when LibreCAD is build with Qt5. I don't know where to solve this for OSX.

Armin
Loading...