Unable to run lua Script in LibreCAD 3

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unable to run lua Script in LibreCAD 3

Amarjeet Kapoor
hi, I am tried to run example on LibreCAD manual
http://wiki.librecad.org/index.php/LibreCAD_3_-_Lua_Scripting 
But I am getting folowing error [string "d=app.currentDocument();..."]:1: attempt to index a nil value (global 'app'"

Any help regarding this?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to run lua Script in LibreCAD 3

R. van Twisk
Administrator
Amarjeet,

these examples might be out dated.

There are some other examples here, see if these work : https://github.com/LibreCAD/LibreCAD_3/blob/master/lcadluascript/lcadluascript.cpp

Ries


On 19 Sep 2016, at 03:13, Amarjeet Kapoor [via LibreCAD] <[hidden email]> wrote:

hi, I am tried to run example on LibreCAD manual
http://wiki.librecad.org/index.php/LibreCAD_3_-_Lua_Scripting 
But I am getting folowing error [string "d=app.currentDocument();..."]:1: attempt to index a nil value (global 'app'"

Any help regarding this?


If you reply to this email, your message will be added to the discussion below:
http://forum.librecad.org/Unable-to-run-lua-Script-in-LibreCAD-3-tp5714246.html
To start a new topic under LibreCAD-user, email [hidden email]
To unsubscribe from LibreCAD, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to run lua Script in LibreCAD 3

Amarjeet Kapoor
On 19 September 2016 at 13:08, R. van Twisk [via LibreCAD]
<[hidden email]> wrote:
> Amarjeet,
>
> these examples might be out dated.
>
> There are some other examples here, see if these work :
> https://github.com/LibreCAD/LibreCAD_3/blob/master/lcadluascript/lcadluascript.cpp
>

I tired Lua code in above link but after that even LibreCAD is also not opening

amarjeet@amarjeet-Inspiron-3521:~/projects/LibreCAD_3/build/lcUI$ ./librecad
log4cxx: Could not open file [Log4cxxConfig.xml].


--
Amarjeet Singh
https://amarjeetkapoor1.wordpress.com
https://github.com/amarjeetkapoor1
https://bitbucket.org/amarjeetkapoor

"The journey of a thousand commit begins with a single init"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to run lua Script in LibreCAD 3

R. van Twisk
Administrator
Don’t worry about,

log4cxx: Could not open file [Log4cxxConfig.xml]. 

It’s a warning, not an error. If LibreCAD doesn’t open (I assume you mean start) it’s not because of that.

Ries

On 20 Sep 2016, at 11:39, Amarjeet Kapoor [via LibreCAD] <[hidden email]> wrote:

On 19 September 2016 at 13:08, R. van Twisk [via LibreCAD]
<<a href="x-msg://21/user/SendEmail.jtp?type=node&amp;node=5714250&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
> Amarjeet,
>
> these examples might be out dated.
>
> There are some other examples here, see if these work :
> https://github.com/LibreCAD/LibreCAD_3/blob/master/lcadluascript/lcadluascript.cpp
>

I tired Lua code in above link but after that even LibreCAD is also not opening

amarjeet@amarjeet-Inspiron-3521:~/projects/LibreCAD_3/build/lcUI$ ./librecad
log4cxx: Could not open file [Log4cxxConfig.xml].


--
Amarjeet Singh
https://amarjeetkapoor1.wordpress.com
https://github.com/amarjeetkapoor1
https://bitbucket.org/amarjeetkapoor

"The journey of a thousand commit begins with a single init"



If you reply to this email, your message will be added to the discussion below:
http://forum.librecad.org/Unable-to-run-lua-Script-in-LibreCAD-3-tp5714246p5714250.html
To start a new topic under LibreCAD-user, email [hidden email]
To unsubscribe from LibreCAD, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to run lua Script in LibreCAD 3

Amarjeet Kapoor
On 20 September 2016 at 15:16, R. van Twisk [via LibreCAD]
<[hidden email]> wrote:
> Don’t worry about,
>
> log4cxx: Could not open file [Log4cxxConfig.xml].
>
> It’s a warning, not an error. If LibreCAD doesn’t open (I assume you mean
> start) it’s not because of that.
>

I know that as It used to appear even before LibreCAD doesn't open GUI
interface . I just posted that to show that even no error is shown on
terminal.

And I think we can't say it doesn't start as after ./librecad command
it doesn't exit but Just GUI is not shown.


--
Amarjeet Singh
https://amarjeetkapoor1.wordpress.com
https://github.com/amarjeetkapoor1
https://bitbucket.org/amarjeetkapoor

"The journey of a thousand commit begins with a single init"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to run lua Script in LibreCAD 3

R. van Twisk
Administrator

On 20 Sep 2016, at 11:53, Amarjeet Kapoor [via LibreCAD] <[hidden email]> wrote:

On 20 September 2016 at 15:16, R. van Twisk [via LibreCAD]
<<a href="x-msg://24/user/SendEmail.jtp?type=node&amp;node=5714252&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
> Don’t worry about,
>
> log4cxx: Could not open file [Log4cxxConfig.xml].
>
> It’s a warning, not an error. If LibreCAD doesn’t open (I assume you mean
> start) it’s not because of that.
>

I know that as It used to appear even before LibreCAD doesn't open GUI
interface . I just posted that to show that even no error is shown on
terminal.

And I think we can't say it doesn't start as after ./librecad command
it doesn't exit but Just GUI is not shown.

Ok,

please let us know the solution and what happened.

Ries



--
Amarjeet Singh
https://amarjeetkapoor1.wordpress.com
https://github.com/amarjeetkapoor1
https://bitbucket.org/amarjeetkapoor

"The journey of a thousand commit begins with a single init"



If you reply to this email, your message will be added to the discussion below:
http://forum.librecad.org/Unable-to-run-lua-Script-in-LibreCAD-3-tp5714246p5714252.html
To start a new topic under LibreCAD-user, email [hidden email]
To unsubscribe from LibreCAD, click here.
NAML

Loading...