Units not preserved across different software

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Units not preserved across different software

CADUSER12345
I am having an issue that may or may not be a librecad issue: When I create a drawing with the Application Preferences and the Current Drawing Preferences both set to units in inch saved as 'Drawing Exchange DXF 2007'. Then when the file is opened with another software package, for example Solidworks or Freecad the drawing units are not preserved.

For example I sent out a drawing of a part that was 36 inch x 36 inch but when the machinist opened it in solidworks it was represented as 36 mm x 36 mm and had to be scaled. The same issue occurs when the file is opened with FreeCAD 0.16

The question is: Does the DXF file format have some unit parameter that is being omitted by LibreCAD and when not detected the other programs are defaulting to mm? Or does DXF 2007 have no provision for this information? Or is it an issue with FreeCAD and Solidworks DXF import?
Reply | Threaded
Open this post in threaded view
|

Re: Units not preserved across different software

CADUSER12345
- Created a simple DXF 2007 file with Application and Drawing preferences set to units of Inch
- Looking at the DXF file I see the following TAG:
$MEASUREMENT
 70
    1
  9

- From the DXF reference the tag $MEASUREMENT should be set as follows: $MEASUREMENT 70 Sets drawing units: 0 = English; 1 = Metric
Autodesk link

- It looks to me this tag should be set to 0. Perhaps this is the issue with the import to other programs?
Reply | Threaded
Open this post in threaded view
|

Re: Units not preserved across different software

CADUSER12345
Found Bug report #636 on this.
https://github.com/LibreCAD/LibreCAD/issues/636
Reply | Threaded
Open this post in threaded view
|

Re: Units not preserved across different software

CADUSER12345
In reply to this post by CADUSER12345
Specifically with FreeCAD 0.16, setting this $MEASUREMENT tag to 0 by manually editing the file did not make any difference.