Colors of library objects

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Colors of library objects

Unterbach
Hi,

I would like to have all drawings in one layer in the same color. I am wondering how to do it with objects from the library.

So, I have assigned a color to that layer (blue).
When I added an object from a library, it is added correctly to the active new layer. But it is drawn in the default color black.
Trying to change the color via "properties" or "attributes" also failed.

How do I change the colour* of objects/blocks taken from the library?


Thanks,

from Unterbach

*) yes, intentionally with "ou" here to increase the impact of search results. :-)
Reply | Threaded
Open this post in threaded view
|

Re: Colors of library objects

Gary S
That may be necessary to "explode"  the blocks and change the colour attribute of the entities that made up the block to "By Layer".  Alternatively, you can try to "Edit the active block..." and change the attributes there to "By Layer".
Reply | Threaded
Open this post in threaded view
|

Re: Colors of library objects

Jaycad
In reply to this post by Unterbach
I've created my library objects on the default layer 0.  When I import them into my drawing they come in on the current layer and the correct colour for that layer.  I think the libary object has to be on layer 0 for this to happen.  

When i import a library object created on a different layer from 0, it imports its own layer to the file and comes in on that layer, rather than adopting the drawing's current layer.