It seems the library browser doesnt see my libraries

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

It seems the library browser doesnt see my libraries

Clinton
Hi! I am a brand new LibreCAD fan.  I use Debian testing (bookworm), where the currently available LibreCAD is 2.1.3  I am quite curious about libraries of architectural objects (furniture, fittings) and I have unziped "Architect3_LCAD" This results in a number of files such as:
~/CAD/LibreCAD/Library/Architect8-LCAD/Furniture8/Complete8
If I run librecad from within this directory and click on Library Browser, I only get other directories ("algorithm', 'block', etc...) but no furniture.  Clearly I am misunderstanding the procedure.  Can anyone help?
Reply | Threaded
Open this post in threaded view
|

Re: It seems the library browser doesnt see my libraries

LordOfBikes
Administrator
The starting location has no effect to libraries.

Instead you should add the path, where your libraries are, to Application Preferences -> Paths setting.
Presumably you have to restart LibreCAD to apply this setting, but then all sub folders, containing DXF files, should be listed in the Library Browser.

see also https://forum.librecad.org/Blocks-External-Library-tp5716343p5716346.html