Librecad not opening files

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view

Librecad not opening files

Librecad is no longer opening DXF files.
When I go to File->Open all DXF files are greyed out.
If I navigate to the file in my file system and double-click it then Librecad opens a new document.
I can save a new file but then I can't reopen it.
I've deleted Librecad and reinstalled.
Per the post from a few months ago I made sure that the preferences were set to Drawing Exchange files.


Version: 2.1.3
Compiler: Clang 8.0.0
Compiled on: Sep 22 2016
Qt Version: 5.6.1
Boost Version: 1.60.0
System: OS X 10.14
Reply | Threaded
Open this post in threaded view

Re: Librecad not opening files


I reinstalled LibreCad, again, and tried to recreate the issue. And again when I went to File->Open my
finder window came up and showed all of the files in my Librecad folder to be greyed out.
Next I created a new file, saved it and tried to reopen it.
Once again the files in my Librecad folder were greyed out.
But then I tried to open the new file under File->Recent and lo (and behold) the new file and the last most recent were all there.
Next I started to compare the files in the Open dialog with the files that were really in my folder structure and I saw that the names didn't match. And it wasn't until then that I realized that all of the files I could see in the Open dialog were DXF-tilde files (.dxf~).
So then I clicked on the Kind column to reorder the returned results and BOOM!
There they were.