Problem with UNDO on Move/Copy

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with UNDO on Move/Copy

JeffM
Hi,

I'm struggling to find an answer to this in the manual or in previous posts, so any help would be welcome.

Quite often when I move a section of a drawing, which might be made up of many entities, and then try to UNDO, Librecad winds backwards one entity at a time, and doesn't put the entire selection back where it started. Not a problem perhaps if the selection is a handful of entities, but a major problem if its hundreds of entities.

Is this normal, is it a bug, is there a trick I'm missing? My default response to this is to close the drawing and start over, not ideal if you haven't backed up for a while.

Many thanks,

Jeff
Reply | Threaded
Open this post in threaded view
|

Re: Problem with UNDO on Move/Copy

dellus
I can't reproduce this behaviour. Does it happen always, or only sometimes? Only in very large drawings with very many entities? Do you use an older version? I just experienced a freeze when doing a to and fro with undos  and redos with many entities in a trial.
Reply | Threaded
Open this post in threaded view
|

Re: Problem with UNDO on Move/Copy

JeffM
Hi Dellus,

It seems to be doing this consistently at the moment, but it hasn't always performed in this way.

Drawing size seems immaterial, I've just opened a new drawing, have quickly drawn in a couple of dozen entities and it's done exactly the same as with a large multilayer with thousands of entities, whether or not I 'escape' to deselect after the move.

I'm using

Version: 2.2.0-rc1
Compiler: GNU GCC 4.9.1
Compiled on: Feb 16 2018
Qt Version: 5.4.1
Boost Version: 1.53.0
System: Windows (10 64bit)

I may try a re-install.

Thanks,

Jeff

 
Reply | Threaded
Open this post in threaded view
|

Re: Problem with UNDO on Move/Copy

LordOfBikes
Administrator
Jeff,

there were indeed some improvements, in late 2018, on the undo/redo framework.
So chances are good, that a newer release will solve your issues.

You can use the latest nightly build for Windows here:
https://sourceforge.net/projects/librecad/files/Windows/NightlyBuilds/master/LibreCAD-Installer-2.2.0-rc1-142-ge38b7088.exe/download

This version should be as stable or even more stable than your current version.

Armin
Reply | Threaded
Open this post in threaded view
|

Re: Problem with UNDO on Move/Copy

JeffM
Thanks Armin, that seems to have fixed the problem.
Reply | Threaded
Open this post in threaded view
|

Re: Problem with UNDO on Move/Copy

LordOfBikes
Administrator
Glad to hear that.
You're welcome.