Relative Zero not locking...bug?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Relative Zero not locking...bug?

Beekeeper
So here's what I'm trying to do:  Make a line from the relative zero (not the absolute zero (red cross))

I set the relative zero (snap>set relative zero...then I click a place on the screen and the relative zero symbol is placed where i clicked.

I lock the relative zero (snap>lock relative zero)

Then I go to the command line and type: line (enter)

It tells me tom enter the coordinates...I do and they are ALWAYS set from the absolute zero, NOT the relative zero.

What gives?  Is this some sort of bug?

Thanks in advance.  I tried searching and found someone going step-by-step...I followed it, but it didn't work.
Reply | Threaded
Open this post in threaded view
|

Re: Relative Zero not locking...bug?

sp1der
Beekeeper wrote
Then I go to the command line and type: line (enter)

It tells me tom enter the coordinates...I do and they are ALWAYS set from the absolute zero, NOT the relative zero.
When entering 'Relative' coordinates in the command line you will always need to add the symbol @ in front of them, for example:
@100,100

@45<,100

etc...
Reply | Threaded
Open this post in threaded view
|

Re: Relative Zero not locking...bug?

Beekeeper
THANKS!

I wish it said something about that in any of the write-ups or manuals.  Maybe I missed it, but hopefully someone will find this thread in the future and not have the same problem.  LibreCAD rocks!
Reply | Threaded
Open this post in threaded view
|

Re: Relative Zero not locking...bug?

Beekeeper
In reply to this post by Beekeeper
Just tried it.  Works great!!

I just didn't read carefully enough.  I was tired!
BLB
Reply | Threaded
Open this post in threaded view
|

Re: Relative Zero not locking...bug?

BLB
In reply to this post by Beekeeper
Um...the response that the thread shows was deleted. Mind sharing what worked for you? The manual with LibreCAD was disabled, so this item is a bit obscure.
Reply | Threaded
Open this post in threaded view
|

Re: Relative Zero not locking...bug?

LordOfBikes
Administrator
Hi,

the deleted post seems to be an issue with Nabble, maybe it returns again.

However, the solution was to enter relative coordinates with a leading @.
Enter coordinates, e.g. 100,100 is absolute from the origin (big red cross).
Enter @100,100 is the position 100 to the right and 100 up from the relative zero position (small red crossed circle).

Armin