Zoom pan constantly on and hiding text

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Zoom pan constantly on and hiding text

skanon
Hi,

For some reason zoom pan has taken control of my work. It is permanently on - even without me clicking or highlighting it). When I pan using it, the text disappears completely and all I see are empty boxes. I really do need to see text on the drawing, not print preview.

Is there a way of totally disabling zoom pan? I prefer scroll bars, which I have ticked in App Preferences.
To do the obvious, I unticked the scroll bars, saved file, closed all, reopened, ticked scroll bars. Result = no change. Zoom pan not highlighted but still operating. No amount of kills/esc stops it.

BTW, what are the ## when saving files? And why are there 2 identical .dxf files showing, though with different time?

Thanks in advance

Version: 2.2.0-rc1-254-g9f2c32dd
Compiler: GNU GCC 4.9.2
Compiled on: Jun 12 2020
Qt Version: 5.5.1
Boost Version: 1.65.1
System: Windows 10
Reply | Threaded
Open this post in threaded view
|

Re: Zoom pan constantly on and hiding text

marus_b
I'm wondering if there is anything being done to resolve this issue?  I'm experiencing exactly the same scenario.  Rebooting LibreCAD is the only way to get rid of it, until you pan again.
Reply | Threaded
Open this post in threaded view
|

Re: Zoom pan constantly on and hiding text

LordOfBikes
Administrator
Too less information so far and not reproducible for me.

Maybe you can give some more information?
Is the mouse cursor constantly a hand symbol or only when the left button is pressed?
Usually the zoom pan command is quit with ESC or right click, does this change anything when the problem occur?

Possibly this is caused by some kind of keyboard malfunction?
I sometimes have the CTRL key locked, when I'm using remote sessions.
It seems context switching keeps the CTRL key flag active even when the key is released.
Pressing the CTRL keys again, left and right, one by one, usually solve the issue for me.
Because CTRL - left click is the shortcut for zoom pan, this could be a possible source for constant zoom pan.