hello all JD Nevbro here - excited to use LibreCAD

Previous Topic Next Topic
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view

hello all JD Nevbro here - excited to use LibreCAD

JD NevBro
Hopefully a simple fix... after playing around with a tutorial link:

I have a new Levono Yoga Windows 11 laptop, running out of box running several typical programs including LibreOffice.

Initially I got errors trying to open an unzipped dxf file "little house project.dxf" and after that I tried several other downloaded dxf files. Same error message:

Cannot open the file
C:\Program Files (x86)\LibreCAD
Please check its existence and permissions.

I figured out a workaround... I placed the dxf file in the C:\Program Files (x86)\LibreCAD folder and it opened. It did make me use my Admin privileges. It may be some path default rights that I'm not sure is from LibreCAD or my PC configuration.

Any insights what may be goin on or could this basic workaround help others
? No big deal as I think I can use downloaded dxf files now.



Reply | Threaded
Open this post in threaded view

Re: hello all JD Nevbro here - excited to use LibreCAD

Welcome JD NevBro!

I believe Windows started with Vista already to protect the Program Files folders.
So I assume, when you unzipped DXF files to the program folder, you had to grant admin privileges too.

Generally you should keep any kind of document files in your user space or any other place than the Program Files folder.

Windows has a mechanism for compatibility reasons with older software. When an application writes to any file in its program folder, it creates a writable copy in a shadow folder in user space.
This prevents older software to stop working because they use e.g. config files, templates or temp files in their program folder. The mechanism is transparent for the application, but has some drawbacks too.
When the application is started with admin privileges, the files from Program Files folder are used, but as regular user it uses the shadow copies. This can make the application look or behave different with or without admin privileges.

Possibly this roaming mechanism has been dropped with Windows 11 and cause issues now.

So I recommend to make a folder for drawings in your personal documents folder or a writable public folder where you can place DXF files.
Then it should work without admin privileges.
It is strongly recommended to not use any application with admin privileges until it is absolutely needed.

If there are still issues with DXF files outside Program Files, there is another issue on Windows 11.
Then, as a workaround, I suggest to grant write permission to C:\Program Files (x86)\LibreCAD folder. This is almost better and less insecure than starting it with admin privileges.

investing less than half an hour into Search function can save hours or days of waiting for a solution