Can't get rid of copied entity and select a new one for copy past

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't get rid of copied entity and select a new one for copy past

OldNick
Version: 2.1.3
Compiler: GNU GCC 4.9.1
Compiled on: Sep 23 2016
Qt Version: 5.4.1
Boost Version: 1.60.0
System: Windows 7

I wanted to move an entity from Layer 0 to Layer 1, and that is sorted. But now I want to copy and paste something on Layer 2, just to repeat it, not to move it between layers.

I make Layer 0 and 1 invisible, select the entity on Layer 2, then ask to Copy. When I try to paste it, it keeps trying to paste the stuff I moved from Layer 0 to Layer 1.

This happens even if I create a new entity on Layer 2 (a 2 point line) and try to copy and paste that.

I am puzzled. Any help appreciated.

Nick
Reply | Threaded
Open this post in threaded view
|

Re: Can't get rid of copied entity and select a new one for copy past

dellus
Maybe, when trying to put new entities into the clipboard, you didn't close the selection with Enter or did not select a reference point.
Reply | Threaded
Open this post in threaded view
|

Re: Can't get rid of copied entity and select a new one for copy past

OldNick
Ahah! I did not see the reference point call. What is funny is that i had already copied and pasted stuff and I remember nothing about the reference point! Maybe I just clicked randomly and then had another go. Sounds daft, but I am still just picking this up.

Anyway, thanks very much for that.

Nick
Reply | Threaded
Open this post in threaded view
|

Re: EDIT Can't get rid of copied entity and select a new one for copy past

OldNick
In reply to this post by dellus
Sorry. Still confused. It just wasn't like this before, I swear (and right now I am!)

I:
- select an entity
- Edit-Copy
- "Specify reference point"
- I click a spot on the screen and all that happens now is the entity is deselected.

Similar with Tools - Modify- Copy/Move, except when I get the dialogue box and ask to keep original, nothing at all happens: the entity stays selected, but no new instance.


Edit: I reverted to an older version and the problem seems to not be there.

Nick

Reply | Threaded
Open this post in threaded view
|

Re: EDIT Can't get rid of copied entity and select a new one for copy past

dellus
"- I click a spot on the screen and all that happens now is the entity is deselected."

Yes, it's deselected, but is in the clipboard now and can be pasted in the next step.

"Similar with Tools - Modify- Copy/Move, except when I get the dialogue box and ask to keep original, nothing at all happens: the entity stays selected, but no new instance."

Press Escape to deselect.
Reply | Threaded
Open this post in threaded view
|

Re: EDIT Can't get rid of copied entity and select a new one for copy past

OldNick
I am sorry. I have fought this enough. I will stop using it and asking how. Sorry.

Thank you for your efforts to help.

Nick