Dimension scalings

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Dimension scalings

tomas
Librecad version 2.1.0

After reopening a drawing, the dimension scalings are incorrect.

400cm and 350cm dimensions

It seems 400 cm scales into 4 (units) and 350 cm shows as 35. I cannot seem to find what scaling option to change to get it back to show centimeters.

In drawing preferences, general scale and  length factor are both set to 1. Main drawing unit is cm.

Any ideas on how to fix this?
Reply | Threaded
Open this post in threaded view
|

Re: Dimension scalings

LordOfBikes
Administrator
Iirc, there was an issue with that which is solved meanwhile.
There should be an option in Current Drawing Preferences in Dimensions tab.
It is called Linear zeros in current version, I think its name is the same or similar in 2.1.0.
When there remove right is checked, zeros behind the point should be removed.
The issue was, that all zeros on the right were removed, what is wrong of course.
So you can try to uncheck this or update to a newer version, e.g. 2.1.3 or latest nightly build.

Reply | Threaded
Open this post in threaded view
|

Re: Dimension scalings

tomas
Thanks, upgrading to 2.2.0-alpha version helped getting the scaling correct again.

In print preview mode, the dimension now show correctly, but in drawing mode I only see empty boxes.

drawing mode:


print preview:


Same goes for any text in the drawing. I'm using unicode and  text style standard in drawing settings.

Any thoughts, what might be the reason for this?

Reply | Threaded
Open this post in threaded view
|

Re: Dimension scalings

dellus
In the 2.2.0 version it's by purpose to show text simplified as boxes when very small in relation to the screen, and so hardly can be read anyway, to speed up screen rendering. When you zoom in the text should appear. You seem to have a high resolution screen, maybe there is a problem with this.
Reply | Threaded
Open this post in threaded view
|

Re: Dimension scalings

LordOfBikes
Administrator
Reply | Threaded
Open this post in threaded view
|

Re: Dimension scalings

tomas
Indeed, in this case it was draft mode that was accidentially enabled.

Thanks for your help!

Tomas
Reply | Threaded
Open this post in threaded view
|

Re: Dimension scalings

flywire
In reply to this post by tomas
Seems white space around the units is done poorly too. Probably should be a proportion of actual font used rather than hard-coded. Might also apply to some of the other settings.