greek fonts, large file from dwg to librecad

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

greek fonts, large file from dwg to librecad

jimishol
This post was updated on .
I started to use librecad 2.0.4 on jessie debian at work and 2.0.9 on gentoo-testing at home.
Before that I was used some kind dwg map by autocad with greek fonts for roads and used the find text ability and zoom-to to see where a specific road is located. The map was large. 86756 entities with 33344 texts counted by autocad. With librecad i had not greek fonts on proper (utf-8?) keys. So i rearranged the greeks.lff to get these in proper, for today, keyboard keys and designed a final 's' too. I could not have accents because there had to be two strikes. For example ';+e'. This file is http://jmp.sh/ipaYXod . In order to have greek at unicode i merged greeks-mine.lff to unicode.lff and added the accent symbols. This file is http://jmp.sh/iPEr80g and copied at /usr/share/librecad/fonts/ (Feel free to rename and use them as you like)
Then in autocad i changed all fonts to style 'standard' and saved map as dxf 2000. I opened the dxf with librecad and saved it. Of course autocad don't open the librecad saved file again, considering it 'incomplete'. Librecad put 'standard' font to texts (choosing the style name?). So in terminal i gave the following command.
sed -i 's/standard/unicode-mine/g' newlibrcadfilemap.dxf (Changing all text fonts by one command)
Now i see greek fonts in map with librecad.
But file is large and every action is slow as if all map, not only display window, is redrawed every time even in draft mode (there is no hatch patterns on map). I noticed that librecad uses only one cpu. On gentoo i have 4 cpu s and on jessie 2. With librecad a cpu goes to 100% usage and others below 25%. If more cpu s would be used, performance would be better.
Of course I no longer have the search text ability (i put it here as a possible request) and so I will not use librecad for that large file.
I will try but I m not sure if I will follow this post because i am not used or use other mailing lists.  
I just wanted to share my experience so far.
Thank you
Reply | Threaded
Open this post in threaded view
|

Re: greek fonts, large file from dwg to librecad

ravas
This post was updated on .
I have greatly improved the performance for drawings with a lot of text.
Although you will need to learn how to build from source,
because most of the changes are only available in 2.2.0-alpha (the master branch).
https://github.com/LibreCAD/LibreCAD/wiki/Build-from-source

It looks like 2.1.1 is available for gentoo.
https://packages.gentoo.org/packages/media-gfx/librecad

Reply | Threaded
Open this post in threaded view
|

Re: greek fonts, large file from dwg to librecad

jimishol
This post was updated on .
Very nice to hear it
Unfortunately I need librecad mostly at work where I don't have time (I'm simple employer) and because i lack the time to resolve any problem that would appear, i use debian stable. There, version 2.2.0 is not even at unstable packages.
At home, I believe that gentoo-testing will soon have the last version, so I prefer to wait.
But for new gentoo users who don't like waiting and would like to try the git version now, i think that all it needs is to add
=media-gfx/librecad-9999 **
at /etc/portage/package.accept_keywords file and update world or emerge librecad again
Reply | Threaded
Open this post in threaded view
|

Re: greek fonts, large file from dwg to librecad

ravas
You can use this PPA, which has been recently updated.
https://launchpad.net/~librecad-dev/+archive/ubuntu/librecad-daily
Reply | Threaded
Open this post in threaded view
|

Re: greek fonts, large file from dwg to librecad

jimishol
Today, on gentoo and librecad 2.0.9 i noticed that i can't type greek accent fonts in librecad text window (the ones that require two strokes ";+e"). i can type them to whatever other editor and copy paste them. Librecad was build with qt5 (not qt4) support. On jessie debian with librecad 2.0.4 I type all greek fonts normally.
Is it a version problem? qt5? where should i look? (I use gnome gtk everywhere and input methods are the same)
If it is version problem i  hope next ones will be ok
Reply | Threaded
Open this post in threaded view
|

Re: greek fonts, large file from dwg to librecad

ravas
ὲ inputs correctly with the latest code and Qt 5.6.1 on OS X.

What's the version of Qt5? It could have been a Qt bug that was fixed.
Otherwise it might be an issue with gnome or whatever is responsible for the input.

I want to encourage you to investigate your options for keeping more up-to-date for your company.
In theory your people could be more efficient because of the new custom toolbar / menu system;
and we eliminated a lot of crashes since 2.0.4... not to mention dozens of other compelling reasons.

https://github.com/LibreCAD/LibreCAD/releases
https://github.com/LibreCAD/ChangeLogs/blob/master/developers/r-a-v-a-s/2-1/2-1-0/2-1-0_introduction.md

OpenSUSE Tumbleweed and Arch Linux offer the latest version within a few weeks of its release.

2.2.0 isn't the latest version, it's what's in development.
So you don't really have any reason to wait on gentoo.
Reply | Threaded
Open this post in threaded view
|

Re: greek fonts, large file from dwg to librecad

jimishol
I tried Arch linux and librecad 2.1.2 in virtualbox. I still needed
mine greek fonts i mentioned earlier THAT actually is greeks.lff of
Hershey Rallaz's fonts but...
CONRATULATIONS!! i couldn't believe such a huge improvement
manipulating that full of text large map.
(now i look forward to 'find text' tool ;-))
Well done. 

(For former question of yours, in gentoo that had the input problem i use dev-python/PyQt5-5.7 . At Arch all was normal)
Reply | Threaded
Open this post in threaded view
|

Re: greek fonts, large file from dwg to librecad

jimishol
librecad  2.1.1 came to gentoo-testing. (I have qtcore-5.6.1). Very, unbelievably, fast with my map.dxf file. Congratulation again.
Of all my machines, only this still had the problem with accent greek fonts. They couldn't be input through the mtext window. It turn out to be that gnome and ibus, at least due to some misconfigure of mine, were not cooperate properly. The  solution came from https://fcitx-im.org/wiki/Note_for_GNOME_Later_than_3.6 by removing ibus by:

   If you're using gentoo, try below steps to remove ibus:
   add -i18n use flag to your make.conf, and run:
   emerge --update --newuse --deep @world --ask
   rebuild gnome-shell with -nls use flag
   remove app-i18n/ibus:
   emerge -cav app-i18n/ibus

Reply | Threaded
Open this post in threaded view
|

Re: greek fonts, large file from dwg to librecad

ravas
Thanks for posting your solution.

2.2.0 will include several more performance improvements regarding text.
What is needed is someone inspired to improve performance for splines.