operating layer not highlighted

classic Classic list List threaded Threaded
23 messages Options
12
Reply | Threaded
Open this post in threaded view
|

operating layer not highlighted

claus82
This post was updated on .
Hello, 3
I was asked to test, so I'm trying to contribute, this is my question
when you are operating on a layer, I remember that the layer in which you are operating should be highlited in grey (I mean in the layer list), did developers removed this or it's jues a bug?




in the image down here there is the version that I use is the one that I was asked to test

...the problem is not the problem, the problem is your aptitude about the problem...
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

Rallaz
In my linux system current layer are highlighted, may be Qt/windows bug?

Note: your version do not save dimension text style, update to LibreCAD-Installer-2.0.7-407-gffb7c2b.exe
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

claus82
I don't know Rallaz, in the PC where I've taken the pictures runs under W7 64bit.
Thanks for the advice!
Cla
...the problem is not the problem, the problem is your aptitude about the problem...
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

Mike Hayes
Hi Claus

I've noticed the same thing. It's not a bug.

If you look carefully at your screen from a wide angle you will see the highlighting is actually there. It's just very feint.

It depends on whatever colour scheme you currently have set for Windows itself.

Mike
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

ravas
Administrator
In reply to this post by claus82
I just changed it to PaleGreen (commit).



Thoughts?
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

ravas
Administrator
We can use hex codes. http://www.quackit.com/css/css_color_codes.cfm

Would something more pale be desirable?

#CCFFCC

Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

claus82
Hi guys,
Rallaz, from my pc the highlighting worked and it was the xxxxxxx399 version, I'm downloading the 410, I guess I will have to install this version in my job station too.
Thanks to all, friends.
Cla
...the problem is not the problem, the problem is your aptitude about the problem...
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

sp1der
In reply to this post by ravas
ravas wrote
We can use hex codes. http://www.quackit.com/css/css_color_codes.cfm

Would something more pale be desirable?

#CCFFCC

To me this is great.

By the way any chance of adding in the proper colors in the 'Application' preferences instead of  just numbers?
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

ravas
Administrator
Yes. You can currently type in anything from that link.
You can suggest some defaults if you want.
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

sp1der
No I was asking if there could be default 'true colours' added showing the colour - not just numbers. I know I can type any numbers,l'm not asking about that.
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

claus82
Thanks guys! Do you think you can do the same for the block list? (I mean having the green highlighted block)

Moreover, in order to empower the potetntial to LC, it would save a lot of time if it could be possible to have multiple selection for layers and blocks, with a "select all"/ "deselect all" option too.
What do you think? But I think this is a feature request.

I can give you immediately an example of the help that it would give this feature:
today I had to open a file with a lot of blocks, (believe me, they were really too many) and activate several layers to clean up that draw. I'm pretty sure that I'm not the only one having this kind of problems, especially if here there is someone that has to do with "proprietary" files.

Any opinion/suggest welcome
...the problem is not the problem, the problem is your aptitude about the problem...
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

ravas
Administrator
In reply to this post by sp1der
sp1der, I meant that you can type in any word from that link such as "PaleGreen",
and that adding words as defaults is possible. There is also QColorDialog, which I might try to implement.
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

ravas
Administrator
In reply to this post by claus82
claus82 wrote
Do you think you can do the same for the block list? (I mean having the green highlighted block)
We are probably going to make an option,
so that users can choose the selection color for all these cases.

Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

LordOfBikes
Administrator
quod erat demonstrandum
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

claus82
In reply to this post by ravas
Very good!
Cla
...the problem is not the problem, the problem is your aptitude about the problem...
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

sp1der
In reply to this post by ravas
ravas wrote
sp1der, I meant that you can type in any word from that link such as "PaleGreen",
and that adding words as defaults is possible.
Okay thanks for the explanation.

 
ravas wrote
There is also QColorDialog, which I might try to implement.
Yes this would be a big improvement if you have the time to do it, thanks very much ravas for your effort for LibreCAD, its people like you that are going to make LibreCAD the best open source program for CAD.
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

ravas
Administrator


I implemented the QColorDialog for the existing color options,
and added an assortment of named colors to the default drop down list.

One thing to note is that if the current color is black,
you need to adjust the vertical slider on the right
before the area to its left works as expected.

Adding the layer / block selection color option is next.
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

ravas
Administrator
I'm thinking it might be useful to have a hotkey for the preference window.
Any thoughts?
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

sp1der
In reply to this post by ravas
ravas wrote


I implemented the QColorDialog for the existing color options,
and added an assortment of named colors to the default drop down list.
Hey, just seen this, this is much better, thanks very much.
ravas wrote
Adding the layer / block selection color option is next.
Nice, I'm looking forward to it, its these little changes that make using the program all that much better for the end user.
Reply | Threaded
Open this post in threaded view
|

Re: operating layer not highlighted

sp1der
In reply to this post by ravas
ravas wrote


I implemented the QColorDialog for the existing color options,
and added an assortment of named colors to the default drop down list.

One thing to note is that if the current color is black,
you need to adjust the vertical slider on the right
before the area to its left works as expected.

Adding the layer / block selection color option is next.
This is working in Windows just fine but not with Ubuntu, even after updating/upgrading?
12