Vertical Dimension Not Save Correctly

Previous Topic Next Topic
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view

Vertical Dimension Not Save Correctly


I created a new file in LibreCAD, did some drawing, dimensioned it and then saved it. Later I reopened the file and the vertical dimensions had gone haywire, maybe I'd say they'd tried to turn into horizontal dimensions? I've tried redoing the dimensions but again after saving they haunt me...

I checked older files from a while back and they did the same. I even tried to open in QCAD and that also did the same on newly saved files but not on older files not resaved...

I'm using Fedora 36 with the latest repository package for FreeCAD.

P.S. There were also issues with LibreCAD finding fonts after upgrading last, IDK if that's related?

Many thanks for any help

Version: 2.2.0-alpha
Compiler: GNU GCC 12.2.1
Compiled on: Sep 24 2022
Qt Version: 5.15.5
Boost Version: 1.76.0
System: Fedora Linux 36 (Workstation Edition)
Reply | Threaded
Open this post in threaded view

Re: Vertical Dimension Not Save Correctly

This is a duplicate of

This issue happened by applying an invalid patch for libdxfrw, reported from Mageia distro, a branch of Fedora.
You must contact Fedora maintainers to request a backport.
They state that Fedora 36 uses 2.2.0-0.13.rc3.fc36 which has also the known and solved font issue.
Fedora 37 uses 2.2.0-0.15.rc4.fc37 which should have the needed fixes.
investing less than half an hour into Search function can save hours or days of waiting for a solution