trim command

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

trim command

Draftsman
I have a drawing with intersecting lines at angles to the X and Y axes. When I try to trim a line, the system won't recognise my limiting entity when I put the cross curser on it and click.
Reply | Threaded
Open this post in threaded view
|

Re: trim command

dellus
When you select the limiting entity it doesn't change to a dotted line, it just changes colour, it gets grey, and you can proceed to select the entity to be trimmed. Is it this?
Or maybe it's not a single line but a rectangle or a polyline, or a block. Trim doesn't work with this. You have to explode it first.
Or maybe it's layer is locked.
Reply | Threaded
Open this post in threaded view
|

Re: trim command

Draftsman
When I click on a line as limiting entity, it doesn't change colour. I tried exploding the whole drawing but it makes no difference.Some of my lines are splines but it doesn't work on these either. Nothing I do makes the line change to grey. I've watched some of the You Tube videos but can't see what I'm doing wrong.
Reply | Threaded
Open this post in threaded view
|

Re: trim command

LordOfBikes
Administrator
Like polylines, splines are also not valid as limiting entity for trimming.
Splines are much more complex and intersection math, which is needed for trimming, is not implemented for them. Also splines could not be exploded.

You can try to start with an empty drawing. Draw two simple intersecting 2-point lines and test how trim or trim-two works with them.
This should eliminate any possible issues which may prevent trimming in your existing drawing.
Reply | Threaded
Open this post in threaded view
|

Re: trim command

Draftsman
Thanks for your response. Having spent thirty years using AutoCAD on a white background, I had made the background on my Librecad drawing white. I tried changing to black and suddenly, the trim works.
Reply | Threaded
Open this post in threaded view
|

Re: trim command

Draftsman
In reply to this post by Draftsman
For the first 15 years of career as an Architect, I was used to drawing black on white and continued this when I switched to AutoCAD. However, Librecad doesn't like a white background. As soon as I switched it to black, the trim command works! Another lesson learned.
Reply | Threaded
Open this post in threaded view
|

Re: trim command

Draftsman
Hi there. Very weird. When I tried the trim un two lines on a black screen, it worked. However, when I start an actual drawing on a black screen, it doesn't work!
Reply | Threaded
Open this post in threaded view
|

Re: trim command

Draftsman
In reply to this post by dellus
Hi there. Very weird. When I tried the trim on two lines on a black screen, it worked. However, when I start an actual drawing on a black screen, it doesn't work!
Reply | Threaded
Open this post in threaded view
|

Re: trim command

dellus
In reply to this post by Draftsman
For me, trim on white background works. Must be something different. Could have to do with the Graphic Colors in Application Preferences - Appearance, for instance Highlighted Color.
Similar with your new problem, maybe line colors pure black or white instead of Black/White, which autoadjusts to background. Have experienced this with drawings imported from different source. Black lines on black background or white on white! You may check with Select All.